Discussions

Ask a Question

Authentication Token

I cannot use CURL for my application and must rely on XMLHttpRequest from Microsoft. I am having difficulties trying to get your site to recognize my Base64 encoded authentication string. I am getting a response back of {"message":"Missing Authenication Token"} Do I provide it in my JSON POST package or does it have to be provided in a different POST? Below is the JSON POST package I am trying to send using Alladin:OpenSesame as the authentication {"Authorization":"Basic QWxhZGRpbjpPcGVuU2VzYW1l"},[{"sku":"ABC","on-hand":1}, {"sku":"ABD","on-hand":2}]
ANSWERED

Trying to query recent orders since last query

Hello, I'm trying to curl order history using min_order_at but keep getting the message: not a valid key=value pair (missing equal-sign) in Authorization header: Any help pointing me in the right direction?

429 'Too Many Requests' on shipments pushed to Shopify orders via the api

I'm seeing some of my shipments in sellbrite fail to push to shopify with the following error: "Failed. Response code = 429. Response message = Too Many Requests." Order ID 104165826 is an example of this. I'm not receiving any Rate Limiting errors from the Sellbrite API - is the push from sellbrite -> shopify having trouble with Rate Limits from them? Is there anything I should be doing on my side to prevent this?

Cost updation using API

It is possible to update price or cost using API?

Curl Patch does not update Inventory

I use this command which is from https://developer.sellbrite.com/v1.0/reference#inventories curl --user <account token>:<secret key> -X PATCH -H "Content-Type: application/json" -d '{ "inventory": [{"sku":"00002640","description":"NEW Snom M9 2640 Combo Kit IP Phones 2 Handsets, 2 Bases, 2 Batteries, 2 Power Supply”,”warehouse_uuid":"e1f883ca-88b2-4548-95bd-bb028ef8bbac"","on_hand":"1"}] }' https://api.sellbrite.com/v1/inventory I tried to change description with same SKU but when I check my inventory with curl --user <account token>:<secret key> "https://api.sellbrite.com/v1/inventory" got respond but nothing is update. the user ID for this account is [email protected] please advice
ANSWERED

POST Shipping to Sellbrite

Every time I try it respond BLANK and it not update the tracking status Here my code: curl -u <authentication_token:secret_key> -H "Content-Type: application/json" -X POST -d '{ "shipment": { "sb_order_seq": "2817", "tracking_number": "1ZR856E10394023680", "carrier_name": "UPS", "items": [{ "sku": "WS-C3750G-24T-S-USED”, "quantity": 1 }]} }' https://api.sellbrite.com/v1/shipments Please Advice, thank you

Issue with API Integration

We are trying to "PUT" information into our API. But we have been getting a runtime error from sellbrite in our integrater. We are using DSYNC and they say everything is working on their side.

Getting Error 403 while updating inventory

I am trying to update inventory for a product as a test but getting Error 403. I am using PHP. Here is the request which I am sending. $inventory_array["inventory"][0] = array ( "sku" => "abcdefg", "warehouse_uuid" => "<the id here>", "on_hand" => 50, ); $unamepwd = "abcdefgh:jklmnopq"; $unamepwd = base64_encode($unamepwd); $api_call = "https://api.sellbrite.com/v1/inventoy"; $ch = curl_init(); curl_setopt( $ch, CURLOPT_URL, $api_call ); curl_setopt( $ch, CURLOPT_HTTPHEADER, array ('Content-type: application/json', 'Accept: application/json') ); curl_setopt( $ch, CURLOPT_CUSTOMREQUEST, "POST"); curl_setopt( $ch, CURLOPT_HTTPHEADER, array("Authorization : Basic ".$unamepwd)); curl_setopt($ch, CURLOPT_HEADER, true); curl_setopt( $ch, CURLOPT_POSTFIELDS, $inventory_array); $result = curl_exec( $ch ); $httpcode = curl_getinfo($ch, CURLINFO_HTTP_CODE); echo "HTTP Code ".$httpcode; Please advice what is wrong in this request. Thanks!

API "404 not found" with "try it!" on https://developer.sellbrite.com

I logged in and I took API Credentials (Account Token and secret key) from the account. I tested with "try it!" on https://developer.sellbrite.com/v1.0/reference#orderssb_order_seq and it show error "404 Not Found". I also tried with Postman and also shown the same error, please advice.
ANSWERED

Sellbrite API for ruby

Where can I find official Sellbrite API for ruby? I am developing app based on shopify api and need to access sellbrite.